Remove corrupt ActiveSync device from Exchange 2010 using MFCMapi

Corrupt ActiveSync device
Sometimes you can get a corrupt ActiveSync device in a Exchange 2010 mailbox.

  • You can see the device in OWA under options > Phone > Mobile phones. 
  • When you try to do anything with the device (Details or Wipe) you will get an error message. 
  • If you in Powershell try to get the ActiveSyncDevices (Get-ActiveSyncDevice -mailbox mailbox_id) you will not see the corrupted device. 
Why is this happening
When a user sets up a ActiveSync relationship the information is stored in two places (AFAIK);

  1. Hidden folders in the user mailbox
  2. AD as child items to the user account

How to fix
This fix deletes the corrupted ActiveSync device that is visible from OWA so a new partnership can be established (or just to remove an orphan device from the list):

  1. Download MFCMapi
  2. Create a MAPI Profile to the users mailbox on a server/workstation with Outlook
    You might as a administrator add [Full Access] permissions to the mailbox that you are going to fix (remember to remove the permissions after the routine is finished)
  3. Start MFCMapi 
  4. Menu Session > Logon [choose the correct Outlook Profile]
  5. Double click the "Mailbox - User name"
  6. Expand the "Root Container"
  7. Expand the "ExchangeSyncData"
  8. Locate the corrupt device (a folder under ExchangeSyncData) and right click > Delete Folder
    [I recommend a hard delete]
  9. Close MFCMapi


Links

7 comments:

Jetti Schnee said...

Thanks your advice was the thing I really needed.
Instantly after I removed it from AD and from MFCMAPI it removed the device was gone.

Jetti Schnee said...
This comment has been removed by the author.
Colin Buckley said...

Perfect!

Simple quick and a the mobile device was gone!

Unknown said...

I am not able to find the "exchangesyncdata" in your instructions. We are using Exchange 2013. Has the location been changed?

Eleanor said...

Did you were able to figure out the location of "ExchangeSyncData" in 2013? I can't find it either.

Unknown said...

Yes I was able to find the object in the mailbox. I had to change the profile to online, then I could see it. We are required to run in cached mode, so creating another profile creates it in cached mode as well.

Chris L said...

Thank you so much for providing this information. I went through so much but this helped me to finally delete the sync to the Outlook app on someone's phone.